it-swarm.dev

Co je to „dist-upgrade“ a proč upgraduje více než „upgrade“?

Zajímalo by mě, proč upgrade někdy nechce upgradovat určité části systému, zatímco dist-upgrade Ano. Zde je příklad po spuštění apt-get upgrade:

apt-get upgrade:

[email protected]:~$ Sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

versus apt-get dist-upgrade:

[email protected]:~$ Sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-3.0.0-13 linux-headers-3.0.0-13-generic
  linux-image-3.0.0-13-generic
The following packages will be upgraded:
  linux-generic linux-headers-generic linux-image-generic
3 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 48.5 MB of archives.
After this operation, 215 MB of additional disk space will be used.
Do you want to continue [Y/n]?

Jinými slovy, proč to nelze provést pomocí upgrade?

418
Richard Rodriguez

Z apt-get manual :

upgrade
   upgrade is used to install the newest versions of all packages
   currently installed on the system from the sources enumerated in
   /etc/apt/sources.list. Packages currently installed with new
   versions available are retrieved and upgraded; under no
   circumstances are currently installed packages removed, or packages
   not already installed retrieved and installed. New versions of
   currently installed packages that cannot be upgraded without
   changing the install status of another package will be left at
   their current version. An update must be performed first so that
   apt-get knows that new versions of packages are available.

dist-upgrade
   dist-upgrade in addition to performing the function of upgrade,
   also intelligently handles changing dependencies with new versions
   of packages; apt-get has a "smart" conflict resolution system, and
   it will attempt to upgrade the most important packages at the
   expense of less important ones if necessary. So, dist-upgrade
   command may remove some packages. The /etc/apt/sources.list file
   contains a list of locations from which to retrieve desired package
   files. See also apt_preferences(5) for a mechanism for overriding
   the general settings for individual packages.

A s novějším apt nástrojem dostupným od 14.04:

full-upgrade
   full-upgrade performs the function of upgrade but may also remove
   installed packages if that is required in order to resolve a
   package conflict.

Ve vašem konkrétním případě například vidím, že linux-headers je virtuální balíček poskytovaný oběma linux-headers-3.0.0-12 a linux-headers-3.0.0-13 a to zní jako druh instalace a odebrání balíčku zpracovaný dist-upgrade, ale ne upgrade.

340
jcollado

apt-get upgrade Je omezen na případ, kdy mají být balíčky nahrazeny novějšími verzemi, ale žádný balíček není třeba přidávat ani odebírat. Například nová verze Firefoxu by měla být nainstalována s apt-get upgrade.

apt-get upgrade Však odmítne fungovat, pokud jsou v aktualizovaných verzích vyžadovány doplňky nebo odstranění. Například pokud máte nainstalované jádro linux-image-3.2.0-10-generic A objeví se linux-image-3.2.0-11-generic, Balíček linux-image-generic Bude aktualizován v závislosti na novější verzi. Chcete-li nainstalovat nové jádro, musíte spustit apt-get dist-upgrade.

Všimněte si, jak apt-get upgrade Řekne, že balíčky jádra byly held back. To je narážka na použití apt-get dist-upgrade.

143
pablomme

Aktualizace v podstatě upgraduje pouze stávající balíčky z jedné verze na druhou. Nainstaluje nebo neodstraní balíčky, i když je to nutné k upgradu ostatních. V případě aktualizací jádra vyžaduje upgrade balíčku linux-generic instalaci nového balíčku linux-3.0.0-13-generic, a protože upgrade odmítá instalovat nebo odebírat balíčky, odmítá upgradovat linux-generic.

Někdy různé kompatibility mezi balíčky vyžadují, aby některé balíčky byly odstraněny, aby se upgradovaly ostatní, a to také bude vyžadovat dist-upgrade. Aktualizace jádra budou vždy vyžadovat dist-upgrade kvůli způsobu jejich zpracování. Spíše než mít aktualizovaný balíček jádra je pokaždé vytvořen zcela nový balíček jádra a metapalíček jádra je aktualizován, aby závisel na novém balíčku jádra místo starého. To bylo provedeno tak, že budete udržovat staré verze jádra, takže v případě problému se zaváděním nového jádra si můžete vybrat starý z bootovací nabídky a obnovit.

34
psusi

Příkaz apt-get upgrade normálně nainstaluje aktualizace (nebo opravy) pouze do aktuálně nainstalovaných balíčků. Obvykle by bylo tímto příkazem nainstalováno nové vydání Mozilla Firefox .

apt-get upgrade Však NE obecně nainstaluje nová vydání, kde hlavní změny (včetně odebrání balíčků nebo GRUB je vyžadována aktualizace). Například pokud je k dispozici nové linuxové jádro (linux-image-3.xx-xx-generic atd.), balíček se nenainstaluje.

Chcete-li nainstalovat nové jádro, musíte spustit apt-get dist-upgrade. Budete upozorněni, když spustíte apt-get upgrade, protože řekne, že některé balíčky byly pozastaveny. To je vaše narážka, kterou chcete použít: apt-get dist-upgrade.

11
david6

Vaše nejlepší volba je:

apt full-upgrade

- které automaticky zpracovává závislosti při aktualizaci balíčků; zatímco:

apt upgrade

- Při aktualizaci balíčků NEBUDOU automaticky zpracovávány závislosti.

-duBtrotterS

2