it-swarm.dev

Jak odstraním zásobník LAMP, abych mohl začít znovu?

Chtěl bych začít od svého webového serveru a chtěl bych přeinstalovat všechny balíčky LAMP, jak to mám udělat?

37
Jorge Castro

Sudo apt-get purge mysql-server Apache2 php5

Tím se odstraní balíčky „big-boy“, které by se měly starat o většinu případů.

Tyto informace najdete v dokumentace , konkrétně v této části , jak začít znovu:

Chcete-li odebrat zásobník LAMP, odeberte následující balíčky:

Poznámka: Předpokládá se, že nemáte žádné jiné programy, které vyžadují žádný z těchto balíčků. Možná budete chtít nejprve simulovat toto odebrání a odebrat pouze balíčky, které nezpůsobí odstranění něčeho požadovaného.

Sudo apt-get remove Apache2 Apache2-mpm-prefork Apache2-utils Apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-Perl libdbi-Perl libmysqlclient15off libnet-daemon-Perl libplrpc-Perl libpq5 mysql-client-5.0 mysql-common mysql-server mysql-server-5.0 php5-common php5-mysql

Chcete-li také odstranit data debconf, použijte při odstraňování možnost čištění. Chcete-li se zbavit všech konfigurací, které jste mohli provést v Apache, ručně odeberte adresář/etc/Apache2, jakmile budou balíčky odstraněny.

Nepoužívejte taskel k odstraňování balíčků, může se stát, že se mohou stát špatné věci, to je obsaženo v tomto hlášení o chybě .

Zbytek dokumentace se týká toho, jak byste přeinstalovali Apache a vše, co potřebujete, abyste mohli znovu začít.

46
Paul Tagliamonte

Odstranit LAMP

Sudo apt-get purge libapache2-mod-auth-mysql phpmyadmin
Sudo apt-get purge mysql-server mysql-server-5.1 mysql-server-core-5.1
Sudo apt-get purge Apache2 Apache2-mpm-prefork Apache2-utils Apache2.2-bin Apache2.2-common libapache2-mod-php5
Sudo apt-get autoremove

Nainstalujte LAMP

Spustit tasksel Vyberte server LAMP.

Chcete-li plně spravovat svou databázi lampových serverů, nainstalujte phpmyadmin

Sudo apt-get install phpmyadmin

9
Achu
Sudo apt-get purge Apache2 php5-cli Apache2-mpm-prefork Apache2-utils Apache2.2-common \
     libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-Perl libdbi-Perl \
     libnet-daemon-Perl libplrpc-Perl libpq5 mysql-client mysql-common mysql-server \
     php5-common php5-mysql phpmyadmin \
&& Sudo apt-get autoremove
2
sukumar

novou verzi LAMP Stack lze odinstalovat pomocí

$ Sudo /opt/lampstack-[version]/uninstall

např

$ Sudo /opt/lampstack-7.1.22-2/uninstall
0
raksa eng