it-swarm.dev

E: Chyba, pkgProblemResolver :: Vyřešit generované přestávky, může to být způsobeno pozastavenými balíčky

Nejsem si jistý, co způsobilo tuto chybu, ale tady je to, co říká celá chyba, a také to sedí jako oznámení a brání mi v aktualizaci jakéhokoli softwaru pomocí Správce aktualizací - Poskytněte prosím pomoc nebo řekněte mi, jak zjistit, co opravit to.

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
40
Jesse

Tento příspěvek může vyřešit váš problém. Shrnout,

  1. Otevři /var/log/dist-upgrade/apt.log log soubor v textovém editoru.
  2. Vyhledejte všechny „poškozené“ balíčky a odeberte je pomocí Sudo apt-get remove <package>.

Poznámka: v novějších verzích je protokol umístěn v /var/log/apt/term.log namísto.

20
Pykler

Snaž se:

Sudo apt-get update && Sudo apt-get upgrade

Poté znovu spusťte správce aktualizací.

9
jlb

Problém byl v tom, že jsem měl nainstalované některé balíčky, které neobsahovaly žádnou cestu k upgradu, to znamená, že nejsou k dispozici v programu Precise. Abych to odladil, podíval jsem se na /var/log/dist-upgrade/apt.log_ a identifikuje balíčky, které byly „nefunkční“. Jen jsem musel apt-get remove, proveďte upgrade vydání a poté je znovu nainstalujte.

Někdy, když jdete na upgrade vašeho počítače pomocí apt-get, uvidíte, že balíček je „držen zpět“.

Normálně byste upgradovali stroj, který byste provozovali:

Sudo apt-get update
Sudo apt-get upgrade

Opravit balíčky byly zachovány zpět:

Sudo apt-get dist-upgrade

   // dist-upgrade in addition to performing the function of upgrade,
   // also intelligently handles changing dependencies with new versions
   // of packages; apt-get has a "smart" conflict resolution system, and
   // it will attempt to upgrade the most important packages at the
   // expense of less important ones if necessary. So, dist-upgrade
   // command may remove some packages. The /etc/apt/sources.list file
   // contains a list of locations from which to retrieve desired package
   // files. See also apt_preferences(5) for a mechanism for overriding
   // the general settings for individual packages.

Tím se upgradují balíčky, které mají k dispozici novější verze, a nainstalují se všechny nové závislosti, které jsou k tomu zapotřebí.

1
M.A.K. Ripon

Tuto chybu jsem dostal, když provádím upgrade od 16.04 do 18.04 a ztrátu energie uprostřed.

Takto vypadala chyba a apt-get install -f ji neopravil.

$ Sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 gir1.2-gtk-3.0 : Depends: gir1.2-pango-1.0 (>= 1.40.5) but 1.38.1-1 is installed
                  Depends: libgtk-3-0 (>= 3.22.29) but 3.18.9-1ubuntu3.3 is installed
 hplip : Depends: hplip-data (= 3.17.10+repack0-5) but 3.16.3+repack0-1 is installed
         Depends: printer-driver-hpcups (= 3.17.10+repack0-5) but 3.16.3+repack0-1 is installed
         Depends: libsane1 (>= 1.0.24) but it is not installed
 libhpmud0 : Depends: libsnmp30 (>= 5.7.3+dfsg-1.8ubuntu3~dfsg) but 5.7.3+dfsg-1ubuntu4.2 is installed
 onboard : Depends: onboard-common (< 1.4.1-2ubuntu1.1) but it is not installed
           Depends: onboard-common (>= 1.4.1-2ubuntu1) but it is not installed
           Depends: libhunspell-1.6-0 but it is not installed
           Recommends: onboard-data (>= 1.4.1-2ubuntu1) but 1.2.0-0ubuntu5 is installed
 python3 : Depends: python3.6 (>= 3.6.7-1~) but it is not installed
           Depends: libpython3-stdlib (= 3.6.7-1~18.04) but 3.5.1-3 is installed
 python3-apt : Depends: libapt-inst2.0 (>= 1.6.5~) but 1.2.29ubuntu0.1 is installed
               Depends: libapt-pkg5.0 (>= 1.6.5~) but 1.2.29ubuntu0.1 is installed
 python3-cryptography : Depends: python3-asn1crypto (>= 0.21.0~) but it is not installed
                        Depends: python3-idna (>= 2.1) but 2.0-3 is installed
 python3-gdbm : Depends: libgdbm5 (>= 1.14) but it is not installed
 python3-pil : Depends: libwebp6 (>= 0.5.1) but it is not installed
               Depends: libwebpdemux2 (>= 0.5.1) but it is not installed
               Depends: libwebpmux3 (>= 0.6.1-2) but it is not installed
               Recommends: python3-olefile but it is not installed
 python3-systemd : Depends: libsystemd0 (>= 233) but 229-4ubuntu21.16 is installed
 python3-uno : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2) but 1:5.1.6~rc2-0ubuntu1~xenial6 is installed
               Depends: python3.6 but it is not installed
               Depends: uno-libs3 (>= 5.3.0~alpha) but 5.1.6~rc2-0ubuntu1~xenial6 is installed
 python3.6-dev : Depends: python3.6 (= 3.6.7-1~18.04) but it is not installed
 totem-plugins : Depends: libgtk-3-0 (>= 3.19.4) but 3.18.9-1ubuntu3.3 is installed
                 Depends: liblirc-client0 but it is not installed
                 Depends: libtotem0 (>= 3.26.0-0ubuntu6.2) but 3.18.1-1ubuntu4 is installed
                 Depends: totem (= 3.26.0-0ubuntu6.2) but 3.18.1-1ubuntu4 is installed
                 Depends: gir1.2-totem-1.0 (= 3.26.0-0ubuntu6.2) but 3.18.1-1ubuntu4 is installed
 virtualbox : Depends: python3.6 but it is not installed
              Depends: libgsoap-2.8.60 but it is not installed
              Depends: libpng16-16 (>= 1.6.2-1) but it is not installed
              Recommends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 virtualbox-qt : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
                 Depends: libqt5widgets5 (>= 5.7.0) but 5.5.1+dfsg-16ubuntu7.5 is installed
                 Depends: libqt5x11extras5 (>= 5.6.0) but 5.5.1-3build1 is installed
E: Unmet dependencies. Try using -f.

Zkusil jsem také Sudo apt-get remove balíčky v /var/log/dist-upgrade/apt.log, ale to také nefungovalo.

Tenhle pracoval pro mě

dpkg -l | grep ^iU | awk '{print $2}' | xargs Sudo dpkg --purge 

To odstranilo rozbité balíčky a pak jsem běžel

 apt install -f

Stáhlo a nainstalovalo balíčky.

1
HVNSweeting

Tato chyba může být způsobena neúplnou instalací balíčku.

Máte dvě možnosti: 1) opravit přerušenou instalaci nebo 2) vrátit zpět (nebo odstranit) přerušenou instalaci.

Protože to nebylo výše uvedeno, vrátit se zpět a odstranit nefunkční instalaci, ukončete synaptic (pokud jste stále v ní) a zadejte tyto příkazy do terminálu:

Sudo apt-get update       # Make sure your package list is up to date
Sudo apt-get autoremove   # Removes "no longer required" packages

Poté potvrďte, že poškozené balíčky jsou pryč, vraťte se zpět do synaptické a vyberte Edit | Fix broken packages a neměly by tam být žádné rozbité balíčky.

Všimněte si, že to neopraví nefunkční instalaci, jednoduše vám to umožní pokračovat znovu v synaptické podobě s jinou instalací nebo odebráním atd.

Stalo se to, že jste zahájili instalaci balíčku a poté se částečně probrali, a po instalaci některých závislostí se něco pokazilo, zbylé nevyužité balíčky zůstaly a neúplná instalace.

1
Elliptical view