it-swarm.dev

Problème d'authentification avec mon PPA

J'ai créé un paquet et l'ai téléchargé sur mon PPA. Après sa construction, je suis allé l'installer, mais j'ai été confronté à ce message:

$ Sudo apt-get install stackapplet
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  stackapplet
0 upgraded, 1 newly installed, 0 to remove and 31 not upgraded.
Need to get 17.7kB of archives.
After this operation, 106kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  stackapplet
Install these packages without verification [y/N]?

Pourquoi est-ce que cela m'avertit que les paquets ne sont pas vérifiés?

11
Nathan Osman

Cela est probablement dû à l'absence d'une clé PGP dans votre trousseau APT. Vous pouvez ajouter la clé avec la commande suivante:

Sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 72D340A3

Bien sûr, vous devez remplacer la clé par votre clé PPA.

De plus, la commande suivante ajoutera la clé automatiquement:

Sudo add-apt-repository ppa:user/ppa-name

Après avoir ajouté la clé, vous devez exécuter apt-get update pour télécharger et vérifier la signature.

14
Ressu