it-swarm.dev

Existe-t-il une version sécurisée de Joomla! 1.6 ou 1.7 disponible?

Existe-t-il une version sécurisée de l'ancien Joomla! 1.6.x, ou la série 1.7.x disponible?

7
JacquesR

La réponse courte et longue est non. Vous devez mettre à niveau un site 1.6 ou 1.7 vers au moins la version 2.5.x car il s'agit de la version la plus sécurisée (bien que la version 2.5 approche rapidement en fin de vie). Si vous avez un modèle compatible, vous pourrez peut-être passer à la version 3.3.

7
Andrew Eddie

Tout site Web Joomla et, pour prolonger cela un peu, tout type de logiciel, en particulier ceux à code source ouvert et ceux qui sont exposés publiquement, devrait être à jour pour assurer une sécurité maximale.

Les versions maintenables actuelles de Joomla sont Joomla 2.5 et Joomla 3.3. Joomla 1.6 et 1.7 étaient des versions à court terme et on pourrait dire qu’ils ressemblaient au chemin de la version 1.5 à la version 2.5. Ils n'étaient pas censés rester longtemps, ils sont non maintenus (= pas de correctifs de sécurité, pas de corrections de bugs, pas de support d'extensions), ils ne peuvent donc plus être utilisés en production.

Les mises à jour, en plus du fait qu’elles peuvent ajouter de nouvelles fonctionnalités, traitent des vulnérabilités connues et des problèmes de sécurité. Ces vulnérabilités sont bien connues du public. Par conséquent, une version plus ancienne du logiciel peut facilement être compromise.

Nous devons également garder à l’esprit que les extensions tierces ne sont pas conservées pour ces versions plus anciennes, ce qui laisse encore plus de place aux vulnérabilités et autres incompatibilités possibles avec le logiciel serveur.

Habituellement, la mise à niveau de 1.6, 1.7 à 2.5 et 3.3 est une tâche facile. Mais gardez à l'esprit que cela dépend des conditions spécifiques de chaque site Web, des extensions tierces et du niveau possible de personnalisation et

Il est fortement recommandé de ne pas essayer de mettre à niveau directement sur le site Web en direct et de toujours conserver une copie de sauvegarde du site Web.

1
FFrewin