it-swarm.dev

Quand les classes JxxxLegacy seront-elles obsolètes?

Existe-t-il une période estimée pour la validité de JModelLegacy, JControllerLegacy et JViewLegacy? Quand le passage aux versions 3.x natives aura-t-il lieu?

4
ilias

Donc, techniquement, vous commencez maintenant à passer aux nouvelles classes MVC - rien ne vous en empêche. Par exemple, com_config dans Joomla core utilise déjà les nouvelles classes MVC.

Cependant, comme vous le savez probablement, les classes Jxxx sont quasiment vides et une bonne partie du travail consiste à placer le même niveau de code que dans les classes JxxxLegacy actuelles. Cela signifie que lorsque vous écrivez un composant, vous devez écrire le moins de code possible.

C’est là que j’interviens - je vais écrire un ensemble complet de Jxxx classes pour (probablement) J3.5 probablement dans le cadre de la campagne GSoC de Joomla cette année (2014). Cela impliquera également d’échanger un grand nombre de composants pour utiliser ceux-ci nouveaux (espérons-le, liens Web, newfeeds et contacts, par exemple, pour les 3PD ainsi que certains des composants les plus utilisés en interne, tels que le cache).

Cependant, ces classes ne seront pas disponibles dans J2.5, ce qui signifie que si vous construisez une extension compatible J2.5/3.x, vous ne pourrez PAS les utiliser. En ce qui concerne la suppression - je pense que nous allons supprimer les classes Legacy dans J4.0 mais ce n'est pas acquis - nous pouvons même choisir de les conserver jusqu'à J5 afin de donner suffisamment de temps aux développeurs d'extensions pour effectuer la transition.

10
George Wilson

Les classes héritées ne sont pas encore obsolètes à l'heure actuelle (avec Joomla 3.3). Donc, c'est parfaitement bien de les utiliser pour une extension Joomla 3.

Au plus tôt, nous les déconseillerons s’il existe des classes de remplacement dans le nouveau MVC. Il se peut que le projet GSoC de George Wilson nous le fournisse. Mais tant que les extensions principales utilisent ces classes, il n’a aucun sens de les déconseiller.

La version la plus ancienne pouvant être supprimée (si elle est déconseillée auparavant) sera Joomla 4.0. Donc, pour Joomla 3.x, vous êtes quand même sûr de les utiliser.

1
Bakual

Je pense qu'il n'y a plus de changements à venir dans l'API actuelle (pour éviter toute confusion supplémentaire ou tout bouleversement du B/C).

Joomla 4 serait la prochaine grande itération.

0
Anibal