it-swarm.dev

Quelle est la version maximale de PHP) que Joomla 1.5 exécutera?

J'ai un client avec un vieux Joomla 1.5, ils ne veulent pas mettre à jour cette année, mais leur hôte veut mettre à jour le serveur. Quelle est la version maximale de php que Joomla 1.5 exécutera plutôt que le minimum indiqué?

http://www.joomla.org/technical-requirements.html#footnote-1xPHP
Joomla! versions 1.5.15 and later are compatible with PHP 5.3.

Est-ce que ça fonctionnerait bien sur 5.3.10? Je suppose que cela casserait sous 5.4 mais je trouve difficile de construire une machine de test avec d’anciennes versions à tester. Donc plus de questions d'expérience.

merci

4
tristanbailey

Si vous utilisez Joomla 1.5.14 ou ci-dessous , vous devriez vous en tenir à PHP 5.2 car il peut y avoir quelques fonctions et/ou des extraits de code susceptibles de ne pas fonctionner sur PHP 5.3

Cependant, si vous utilisez Joomla 1.5.15 ou ci-dessus , vous devriez pouvoir mettre à niveau vers PHP 5.3. Si vous utilisez la bibliothèque OpenID, celle-ci ne sera pas compatible avec PHP 5.3 et vous devrez donc soit trouver une alternative, soit vous en tenir à PHP 5.2.

Pour plus d'informations sur les versions de PHP, MySQL et Apache, consultez le Spécifications techniques

Je vous suggère de passer à Joomla 1.5.26, qui est la dernière version de la série 1.5.

J'espère que cela t'aides

5
Lodder

J'utilise un site Joomla 1.5.26 avec un nouveau site J3 en construction sur le même PHP. Le site J1.5 fonctionne parfaitement sur PHP = 5.6 sans aucune modification, le site J1.5 est très simple et n’a que quelques extensions.

4
biltong

Je confirme que Joomla 1.5.24 fonctionne sous PHP 5.5.9-1ubuntu4.17. PHP-FPM a été installé avec un serveur Web apt est nginx. Toutes les fonctionnalités semblent fonctionner correctement.

3
Egeshi