it-swarm.dev

Revers Joomla 2.5.18 à 2.5.16, comment?

J'ai un site qui était à la version 2.5.16 de Joomla, et je l'ai mis à jour à la version 2.5.18. Et fait de nouveaux articles, modifications de menus, etc.

Après la mise à jour, je ne réalisais pas que le site était très endommagé dans la vue des catégories (en raison des substitutions dans les vues, c’était la première fois que cela se produisait, la version 2.5.18 introduisait un paramètre de langue et mes substitutions ne s’appliquaient pas. avoir cela).

J'ai donc essayé de revenir de mes fichiers sauvegardés du 2.5.18 au 2.5.16, mais cela n'a pas très bien fonctionné! (aucun moyen de se connecter à l’administrateur, ou au début, il y avait une page blanche).

J'ai lu que cela avait à voir avec la session, ou les cookies, et j'ai essayé de les vider, mais pas de chance.

J'ai alors compris que cela était dû à une modification de la base de données, mais je n'ai jamais vu de mise à jour d'une version mineure modifiant la base de données. Je ne pouvais pas restaurer ma sauvegarde de la base de données, car j'avais déjà modifié les articles de la version 2.5.18. (Remarque: j'ai fait une copie du site et restauré la base de données à la sauvegarde, et la connexion a fonctionné, ce qui signifie que c'est vraiment la base de données!).

Quelqu'un sait-il s'il est confirmé que la base de données a été modifiée et comment le rétablir correctement en version 2.5.16?

Ou est-ce lié à autre chose?

2
jackJoe

Dans Joomla 2.5.18, un nouveau mot de passe de sécurité, basé sur PHPass, a été introduit.

Lorsqu'un utilisateur précédent revient sur votre site, le mot de passe est crypté avec la nouvelle méthode.

Il n'y a pas de changement de structure de base de données. http://developer.joomla.org/version-2-5-18-release-notes.html

4
Anibal

La réponse est peut-être un peu hors sujet, mais vous devriez vraiment résoudre le problème de mise en page de la catégorie. Ce serait beaucoup plus facile et, du point de vue de la sécurité, une étape nécessaire.

Ou souhaitez-vous rester sur une ancienne version, qui peut-être devenir un problème de sécurité?

0
Harald Leithner