it-swarm.dev

Composant migrant de 2.5 à 3.3

Cette documentation: Adapter une extension Joomla 1.5 à Joomla 2.5

http://docs.joomla.org/Adapting_a_Joomla_1.5_extension_to_Joomla_1.6#Renamed_events

Vraiment m'a aidé lorsque j'ai migré mon composant à la version 2.5.

Je me demande s'il y a quelque chose de similaire qui vous montre comment migrer votre composant de 2.5 à 3.3

Merci

5
Piero Marsilio

Même le lien que vous avez fourni dans votre question ne fournit pas tout ce qui doit être changé lors de la migration d'une extension. Il y a toujours des différences d'API assez importantes entre les versions de Long Term Release de Joomla.

Pour Joomla 3.x, la principale chose que j'ai tendance à regarder est la suivante:

Problèmes de compatibilité avec les versions antérieures de Joomla

En plus de cela, je regarde aussi le dernier site API:

http://api.joomla.org/cms-3/

J'espère que cela t'aides

12
Lodder

Si vous cherchez seulement à le faire fonctionner, les liens fournis par @Lodder aideront énormément à gérer du code obsolète. Un tas de code 3.x a été rétroporté pendant le travail sur la version 2.5.5. Ainsi, si vous ne supportez que cette version ou une version ultérieure, vous pouvez théoriquement faire en sorte qu'un composant fonctionne à la fois avec les versions 2.5 et 3.x. Ce qui n’est pas documenté, ce sont les changements de mise en page fournis avec le passage à Bootstrap; vous aurez besoin d'utiliser les composants de base comme modèle pour cela.

Si vous souhaitez ajouter une prise en charge des fonctionnalités 3.x (telles que les balises ou l'historique du contenu), vous devrez effectuer davantage de travail. Ces liens vous aideront à intégrer le support pour ces fonctionnalités:

4
Michael

Migration du composant de 2.x vers 3.x

renvoyer ce lien,

étape 1: Différence entre 2.x en 3.x

étape 2: Méthodes importantes

2
kumarramalingam