it-swarm.dev

Quand passer à une nouvelle version majeure?

Avec la nouvelle stratégie de développement, il n’y aura pas de version initiale appelée LTS. Avec les informations actuellement publiées, 3.4 remplacera le 3.5 annoncé. En supposant qu'il existe des plans pour 4.0,4.1,4.2,4.3,4.4 à quelle heure les sites doivent migrer vers quelle version.

11
sovainfo

Il y a quelques points à prendre en compte lors de la planification des migrations entre les versions principales. L'un des meilleurs devrait être la date de fin du support ou la date de fin de vie de la version que vous utilisez actuellement; si c'est proche, vous devriez planifier votre déménagement.

Pour les sites Web établis, je vous conseillerais de consulter les fonctionnalités disponibles. Est-ce que la nouvelle version a quelque chose dont vous avez besoin bientôt? Si tel est le cas, commencez à planifier votre migration. Si votre site fonctionne correctement et ne nécessite pas les dernières fonctionnalités, vous pouvez rester sur la version actuelle tant qu'elle est toujours prise en charge.

Si vous migrez, à quoi ressemble le support d'extension? Les extensions que vous utilisez ont-elles une version compatible pour la version vers laquelle vous migrez? Si oui, cela simplifie grandement les choses, mais s’ils ne le font pas, combien d’efforts seront nécessaires pour remplacer leurs caractéristiques par autre chose?

Enfin, chaque version étiquetée comme stable devrait pouvoir être construite, mais personnellement, je serais un peu plus prudent quant à l’utilisation d’une version X.0 ou même de la version X.1, car celles-ci sont généralement plus susceptibles d’avoir des bogues compte tenu de la portée de changement qui peut aller dans une version majeure X.0. Personnellement, je pense que les versions X.2 ou X.3 sont le moment où vous commencez à voir une série de versions mûrir au point d’être prête pour une utilisation majeure.

6
Michael

À partir de Joomla! 3.4 chaque version sera stable et sera prise en charge pendant au moins deux ans, à moins que la nouvelle version mineure ne soit publiée. Si cela se produit, la version mineure précédente ne sera pas prise en charge et la version actuelle sera prise en charge pendant au moins deux ans. Donc, si vous envisagez de migrer vers la série 3.x, vous pouvez le faire en toute sécurité à partir de la v3.4.

La même chose s'applique à la série 4.x - 4.0 sera également stable et prendra en charge au moins deux ans, à moins que la nouvelle version mineure ne soit publiée (par exemple 4.1). Vous pouvez donc migrer vers n’importe quelle version mineure de la série 4.x. Mais gardez à l'esprit que chaque version majeure comporte des modifications incompatibles avec le passé! Donc, cette migration doit être planifiée très soigneusement.

Bien sûr, vous ne devriez pas migrer vers les versions BETA ou RC, car celles-ci sont uniquement à des fins de test.

1
Dmitry Rekun

À ma connaissance, à partir de la version 3.4, vous devez toujours utiliser la dernière version, car celle-ci sera prise en charge pendant 2 ans à compter de sa parution et le support des versions antérieures (3.3, ...) ne sera plus disponible. Toutes les versions d'une série (3.x) seront rétrocompatibles; par conséquent, une mise à jour ne devrait généralement pas poser de problème.

La nouvelle série 4.x supprimera la compatibilité ascendante et vous ne devriez effectuer la mise à niveau que si vous souhaitez utiliser les nouvelles fonctionnalités.

0
fruppel
  1. Si vous démarrez le développement, utilisez la dernière version majeure disponible (utilisez la série 4 lorsque celle-ci est disponible)
  2. Lorsqu'une nouvelle version mineure (3.4) est publiée, attendez que votre version actuelle (3.3) soit prise en charge. Dans le temps, la nouvelle version doit avoir reçu des correctifs de bogues critiques. Ainsi, votre site Web peut maintenant être mis à jour en toute sécurité.

Astuce: Maintenez toujours un site de test avec la même configuration de serveur, pour le tester d'abord, puis utilisez la version.

0
Shyam