it-swarm.dev

Vous devez toujours désactiver Souvenez-vous de moi lors de la migration de la version 2.5 à la version 3.x?

Avec 3.3 et 3.2.4, est-il toujours nécessaire de désactiver le plugin? Se souvenir de moi? Quelle est la raison technique?

4
sovainfo

Pour répondre à la question "Quelle est la raison technique?", J'ai jeté un coup d'œil au traqueur et aux notes GitHub. Le problème semble être double: échec de la suppression de certains fichiers lors de la mise à niveau et impossibilité d'appliquer certaines mises à jour SQL. Cependant, ne concerne que certains et pas d'autres. Voir le bug tracker pour plus d'informations.

L’approche générale des meilleures pratiques semble être la suivante:

Si ce n'est déjà fait ...

  • Sauvegarde!
  • Désactiver System -> Remember Me brancher
  • Faire la mise à jour
  • Activer System -> Remember Me brancher

Si bouché et pas de sauvegarde ...

Lorsque l'installation échoue sur l'url /administrator/index.php?option=com_joomlaupdate&task=update.finalise avec l'erreur php '\ plugins\system\memory\memory.php on line 94'

Exécuter\cli\deletefiles.php à partir de la ligne de commande, puis actualiser le fichier /administrator/index.php?option=com_joomlaupdate&task=update.finalise donne FULL SUCCESS

This commit corrige apparemment le problème, mais suggère que cela a à voir avec $this->app non pré-rempli par le système. Cela vaut également la peine d’y jeter un coup d’œil si cela échoue. Gardez à l'esprit qu'il s'agit d'une demande d'attraction récente (16 avril 2014) et qu'elle n'a pas été approuvée dans le suivi: YMMV.

6
codinghands

Le problème n'apparaît que sur certains serveurs, pour des raisons que je ne connais pas encore exactement. Sur mes serveurs, cela fonctionne sans problème, mais un ami avait également ce problème.

J'ai fait un PR qui, je crois, résoudra le problème, voir https://github.com/joomla/joomla-cms/pull/3467 . Si quelqu'un qui a ce problème peut tester ce correctif et voir s'il corrige le problème, ce serait génial :-)

1
Bakual