it-swarm.dev

Migrer les utilisateurs, les autorisations, les accès, les groupes et le contenu de 1.6 à 3.3.X

Je dois mettre à jour une installation de joomla de 1.6 à une nouvelle version, 3.3.X si tout va bien. Je me suis amusé avec le processus de mise à niveau étape par étape pour passer de version en version. Jusqu'ici, ça ne s'est pas bien passé.

Au lieu de cela, je pensais simplement effectuer une nouvelle installation de la nouvelle version de Joomla 3.3 s’il était possible de migrer ensuite le contenu de l’ancienne installation 1.6.

Est-ce que quelqu'un connaît un moyen de faire ça?

L'installation des nouvelles versions des composants et des extensions ne serait pas difficile, mais il me faudrait déplacer tous les utilisateurs, groupes, niveaux d'accès, ainsi que tous les articles et menus. Bien sûr, les articles et les menus doivent garder leur accès et leur emplacement corrects pour que tout fonctionne. Aussi, je ne veux pas avoir à ré-installer tous les utilisateurs.

Merci pour toute aide!

3
jeffery_the_wind

Réessayez une migration étape par étape:

Faites d'abord une sauvegarde, puis essayez ceci:

  1. Suivez ces instructions pour mettre à niveau Joomla 1.6.x vers Joomla 2.5.x - http://www.ostraining.com/blog/joomla/upgrade-joomla-16-to-25/
  2. Assurez-vous que chaque composant, plugin, modèle est prêt pour Joomla 3.3
  3. Désactiver le plugin Rememberme.
  4. Ensuite, allez à Joomla! Mettre à jour dans le menu Composants, puis cliquez sur le bouton Options
  5. Changez le paramètre du serveur de mise à jour en support à court terme et enregistrez
  6. Ensuite, vous voyez la dernière mise à jour de Joomla et vous pouvez traiter de la manière habituelle.
  7. Activez votre plugin Rememberme.
3
Joomla Agency

Vous devez d’abord vous assurer que vous utilisez Joomla 1.6.5, le dernier-né de la série 1.6. Une fois terminé, accédez à Extensions (menu supérieur) >> Mise à jour >> Purge Cache >> Rechercher les mises à jour.

La mise à jour à l'aide de la fonctionnalité de mise à jour en un clic décrite ci-dessus mettra automatiquement à jour vos tables de base de données, votre code et vos extensions. Vous n'avez donc pas à vous soucier de la migration manuelle des utilisateurs, des autorisations, etc.

Cependant, vous devrez peut-être installer des versions plus à jour des extensions tierces et du modèle que vous avez installés car certaines modifications fondamentales de l'API ont été apportées depuis Joomla 1.6.

J'espère que cela t'aides

2
Lodder