it-swarm.dev

Y a-t-il une raison impérieuse de mettre à niveau Ubuntu 8.04 (Hardy Heron)?

L'installation de mon bureau et de mon serveur est correcte. Suis-je en train de manquer quelque chose d'important qui ferait une mise à niveau en vaut la peine?

10
Aviah Laor

La réponse courte serait:

  • Serveur: non
  • Bureau: peut-être

Le vieil adage "Si ce n'est pas cassé, ne le répare pas." est particulièrement vrai lorsqu'il s'agit de serveurs. Bien que j'aie mis à niveau mon serveur de 8.04 à 10.04, c'est uniquement parce qu'il y avait pas mal de nouvelles bibliothèques que je voulais vraiment. Sauf que 8.04 est toujours une version solide, et s'il n'y a rien que vous pensez explicitement manquer, je pense que vous devriez rester avec.

En ce qui concerne le bureau, le choix est moins évident. Le nouveau 10.04 offrira très probablement une "expérience de bureau" plus agréable et plus soignée. En outre, vous remarquerez beaucoup plus d'améliorations dans le logiciel de bureau inclus que vous ne le faites généralement avec les démons de serveur typiques.

Pourtant, votre bureau 8.04 fonctionne pour vous et même s'il en ira probablement pour le bureau 10.04, un changement entraîne toujours le risque de quelque chose qui ne va pas. Je suppose que cela revient à savoir à quel point il serait lourd/possible pour vous de réinstaller le bureau 8.04 dans le pire des cas.

16
andol

Oui, un énorme travail de sécurité proactif a été effectué entre Hardy et Lucid. Comparez simplement la liste fonctionnalités de sécurité . Par exemple, de nombreuses failles de sécurité qui seraient exploitables sur Hardy sont tout au plus un déni de service sur Lucid.

10
Kees Cook

Cela dépend de vos besoins. Certes, sur le bureau, vous êtes plus susceptible de mettre à niveau car les applications et les fonctionnalités changent de plus en plus rapidement.

Cependant, le serveur a également de nouvelles mises à niveau qui peuvent couper dans les deux sens. Par exemple, php5 a été mis à niveau vers 5.3 qui a beaucoup de nouvelles fonctionnalités très pertinentes pour le langage php (espace de noms, fonctions magiques pour les méthodes statiques dans les objets, etc.). Cependant, de nombreuses applications php plus anciennes ne sont pas compatibles avec php5.3. Par conséquent, vous devez évaluer si l'une de vos anciennes applications est effectuée et si vous avez besoin de ces nouvelles fonctionnalités.

4
txwikinger