it-swarm.dev

Installation de wxPython sur Ubuntu 12.04

Le problème: Je ne parviens pas à installer wxPython sur Ubuntu 12.04. _ {J'aimerais trouver un moyen simple et direct de faire cela.} _

Ce que j'ai fait jusqu'à présent: Les instructions les plus pertinentes que j'ai pu trouver jusqu'à présent se trouvent ici: http://wiki.wxpython.org/InstallingOnUbuntuOrDebian

Le problème avec ces instructions est qu'il n'y a pas de choix disponible pour Precise 12.04. La distribution la plus récente indiquée est Natty 11.4. D'après ce que je peux trouver, le moyen approprié de le faire est de construire manuellement des paquets Debian, ce qui est expliqué ici: http://wiki.wxpython.org/BuildingDebianPackages

En essayant cela et en tapant finalement la commande 'fakeroot debian/rules binary', j'obtiens les erreurs:

debian/rules: 14: /usr/share/quilt/quilt.make: Aucun fichier ou répertoire de ce type
pyversions: X (S) -Python-Version manquante dans le fichier de contrôle, revenir à debian/pyversions
pyversions: fichier debian/pyversions manquant, retour aux versions prises en charge
make: *** Aucune règle pour rendre la cible `/usr/share/quilt/quilt.make '. Arrêtez.

Je n'arrive pas à corriger cette erreur ni à trouver d'autres ressources applicables qui fonctionnent pour moi. Je posterais plus de liens ici, mais comme je suis nouvelle, le filtre anti-spam me bloque.

Conclusion: Est-ce que quelqu'un connaît une solution simple pour installer correctement wxPython sur Ubuntu 12.04 Precise?

Update: J'ai simplement essayé d'utiliser la commande apt-get 'Sudo apt-get install python-wxgtk2.8', et j'ai reçu ceci (ce qui semble bien):

Lecture des listes de paquets ... Terminé
Construire un arbre de dépendance

Lecture des informations d'état ... Terminé
Python-wxgtk2.8 est déjà la dernière version.
Les packages suivants ont été installés automatiquement et ne sont plus nécessaires:
language-pack-zh-hans yaml-cpp language-pack-kde-fr language-pack-kde-zh-hans language-pack-kde-en-base language-pack-zh-hans-base language-pack-kde- zh-hans-base
Utilisez 'apt-get autoremove' pour les supprimer.
0 mis à niveau, 0 nouvellement installé, 0 à supprimer et 173 non mis à niveau.

Mais une fois que j'essaie d'exécuter quelque chose, c'est-à-dire 'python test_gui.py', j'obtiens le message d'erreur suivant:

Traceback (appel le plus récent en dernier):
Fichier "test_gui.py", ligne 1, dans 
importer wx
ImportError: Aucun module nommé wx

15
John Zeller

Ok, alors j'ai été capable de comprendre. Il s'est avéré être une combinaison de choses.

  1. D'abord, assurez-vous d'avoir installé Python
  2. Installez wxGTK 2.8 avec la commande, Sudo apt-get install python-wxgtk2.8
  3. Exécutez la commande, apt-get source -d wxwidgets2.8
  4. Maintenant, lancez, dpkg-source -x wxwidgets2.8_2.8.12.1-6ubuntu2.dsc
  5. cd wxwidgets2.8-2.8.12.1
  6. cd wxPython
  7. Maintenant, lancez la commande, Sudo python setup.py install
  8. wxPython et wxWidgets sont maintenant installés avec succès!
21
John Zeller

D'accord. Donc, j'ai trouvé un moyen de sortir Il suffit d'exécuter la commande suivante dans un terminal: 

Sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-doc wx2.8-examples wx2.8-headers wx2.8-i18n

Et voila! Ça marche!

35
Brut3e

Sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n libwxgtk2.8-dev libgtk2.0-dev fonctionne pour moi

source: http://wiki.wxpython.org/InstallingOnUbuntuOrDebian

9
dev-seahouse

Vous pouvez également l'installer avec Pip, mais avec un légère modification à la commande d'installation.

Sur le site wxPython website :

En raison des différences entre les distributions Linux (principalement Différentes versions des bibliothèques principales installées par défaut, mais Également une architecture de plate-forme, etc.), il n’est pas possible d’héberger du binaire Les fichiers .wheel pour Linux sur PyPI, à moins qu’ils ne puissent fonctionner avec les contraintes de PEP 513 Malheureusement, les tentatives de pilonner le La fixation de wxPython dans le trou de manylinux1 n’a pas été très fructueuse . Peut-être que manylinux2 conviendra mieux. En attendant, si vous avez un Linux assez semblable à ceux utilisés pour construire les roues situées sous le dossier linux wxPython Extras, alors vous pouvez les utiliser sans avoir besoin de construire les roues vous-même.

Puisqu'il existe différentes options pour la distro et le port wx (GTK2 ou GTK3) alors les fichiers ne peuvent pas tous être situés dans le même dossier pour easy accès par pip. Cela signifie simplement que vous devrez approfondir un peu plus loin pour trouver l'URL à donner à pip. Par exemple, pour obtenir le GTK3 wxPython construit pour Ubuntu 16.04 (et 16.10, LinuxMint 18 et Probablement d'autres), vous pouvez utiliser une commande pip comme celle-ci:

pip install -U -f https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ubuntu-16.04 wxPython
1
smac89

gtk3 devrait être installé en premier

$Sudo apt-get libgtk-3-dev

Si vous rencontrez des difficultés pour installer wxpython sur Python3, utilisez cette commande pour installer wxpython.

$ pip install -U -f https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ubuntu-16.04 wxPython

Avec cette commande, vous pouvez installer la dernière version de wxPython4 . Si vous utilisez Windows ou macOS

$ pip install -U wxpython
1
Aryan

Sur Ubuntu 12.04.5 je devais utiliser tout cela

apt-get install python-wxgtk2.8 python-wxtools wx2.8-doc wx2.8-examples wx2.8-headers wx2.8-i18n python-wxversion libwxbase2.8-0 libwxgtk2.8-0
0
Robert