it-swarm.dev

Qual è la versione massima di PHP che verrà eseguito Joomla 1.5?

Ho un client con un vecchio Joomla 1.5 che non vogliono aggiornare quest'anno, ma il loro host vuole aggiornare il server. Qual è la versione massima di php che verrà eseguita da Joomla 1.5 anziché il minimo elencato?

http://www.joomla.org/technical-requirements.html#footnote-1xPHP
Joomla! versions 1.5.15 and later are compatible with PHP 5.3.

Funzionerebbe bene su 5.3.10? Immagino che si rompa su 5.4 ma trovo difficile costruire una macchina di prova con vecchie versioni da testare. Quindi altre domande per esperienza.

grazie

4
tristanbailey

Se stai utilizzando Joomla 1.5.14 o sotto , dovresti attenersi a PHP 5.2 in quanto potrebbero esserci alcune funzioni e/o snippet di codice che potrebbero non funzionare su PHP 5.3

Tuttavia, se stai utilizzando Joomla 1.5.15 o sopra , dovresti andare bene con l'aggiornamento a PHP 5.3. Se stai usando la libreria OpenID, questo non sarà compatibile con PHP 5.3 e quindi dovrai trovare un'alternativa o restare con PHP 5.2

Per ulteriori informazioni su quali versioni di PHP, MySQL e Apache, dai un'occhiata a Requisiti tecnici

Vorrei suggerire l'aggiornamento a Joomla 1.5.26, che è l'ultima versione della serie 1.5.

Spero che sia di aiuto

5
Lodder

Sto gestendo un sito Joomla 1.5.26 insieme a un nuovo sito J3 in costruzione sullo stesso PHP. Il sito J1.5 funziona perfettamente su PHP = 5.6 senza alcuna modifica. Il sito J1.5 è un sito molto semplice con solo poche estensioni.

4
biltong

Confermo che Joomla 1.5.24 funziona su PHP 5.5.9-1ubuntu4.17. PHP-FPM è stato installato con apt. Il server Web è nginx. Tutte le funzionalità sembrano funzionare senza problemi.

3
Egeshi