it-swarm.dev

Joomlaの安全なバージョンはありますか? 1.6か1.7か?

古いJoomlaのany安全なバージョンはありますか? 1.6.x、または1.7.xシリーズが利用可能ですか?

7
JacquesR

短い答えと長い答えはnoです。これは最も安全なバージョンであるため、1.6または1.7のサイトを少なくとも2.5.xにアップグレードする必要があります(ただし、2.5は寿命に近づいています)。互換性のあるテンプレートがある場合は、3.3にアップグレードできる場合があります。

7
Andrew Eddie

JoomlaのWebサイトとこれを少し拡張するために、あらゆる種類のソフトウェア、特にオープンソースのソフトウェアと一般に公開されているソフトウェアを最新の状態にして、最大限のセキュリティを確保する必要があります。

Joomlaの現在の保守可能なバージョンは、Joomla 2.5とJoomla 3.3です。 Joomla 1.6と1.7は短期リリースでしたそして、バージョン1.5から2.5へのパスのようなものであったと言えます。それらは長期間とどまることを意味していなかった、それらはメンテナンスされていない(=セキュリティパッチなし、バグ修正なし、拡張サポートなし)なので、本番環境ではこれ以上使用できません。

アップデートは、新機能を追加する可能性があるという事実のほかに、既知の脆弱性とセキュリティの問題に対処します。これらの脆弱性は一般に知られているため、古いバージョンのソフトウェアが簡単に侵害される可能性があります。

もう1つの条件は、このような古いバージョンではサードパーティの拡張機能も維持されないため、脆弱性やその他のサーバーソフトウェアとの非互換性により多くのスペースが与えられることです。

通常、1.6、1.7、2.5、3.3へのアップグレードは簡単な作業です。ただし、これは各Webサイトの特定の条件、サードパーティの拡張機能、およびカスタマイズの可能なレベルと

ライブウェブサイトで直接アップグレードしようとせず、常にウェブサイトの正常なバックアップを保持することを強くお勧めします。

1
FFrewin