it-swarm.dev

joomla 2.5と3の両方のバージョンのコンポーネントコーディングのmvc方法を理解する

私はjoomla 3で機能しなかったjoomla 2.5のコンポーネントをmvcの方法で作成しましたが、後でそれが判明しました。

JControllerLegacy、JViewLegacy、JModelLegacy

そして、私が知る限り、コンポーネントをjoomla 3と互換性を持たせるために他の変更は必要ありません。j3との互換性について知っておくべきことがあれば、私に知らせてください。だから、joomla 2.5と3の2つの別々のmvcコンポーネントを作成する代わりに、これらのLegacyクラスから拡張して、単一のコンポーネントでjoomla 2.5と3の両方に十分に対応できると思いますか?そして、joomlaの両方のバージョンにインストールできるMVCコンポーネントを作成するために、他にどのようなことを考慮する必要がありますか。

7
dev-m

Joomla 2.5と3.xの違いを説明する適切なドキュメントページがあります。

http://docs.joomla.org/Potential_backward_compatibility_issues_in_Joomla_3_and_Joomla_Platform_12.2

言及すべき唯一のことは、レガシークラスはJoomla 2.5.5以降でのみ利用可能であることです。しかし、とにかく誰もが今日2.5.19にいるはずです:)

8
Bakual