it-swarm.dev

JxxxLegacyクラスはいつ廃止されますか?

JModelLegacyJControllerLegacyおよびJViewLegacyの有効性の推定期間はありますか?ネイティブ3.xへの切り替えはいつ行われますか?

4
ilias

したがって、技術的には、新しいMVCクラスへの移行を今すぐ開始します。何も妨げるものはありません。たとえば、Joomlaコアのcom_configはすでに新しいMVCクラスを使用しています。

ただし、おそらくご存じのとおり、Jxxxクラスはほとんど空であるため、多くの作業で、現在のJxxxLegacyクラスと同じレベルのコードが挿入されます。つまり、コンポーネントを作成するときは、できるだけ少ないコードを書く必要があります。

それが私が出会うところです-おそらく今年(2014年)にJoomlaのGSoCキャンペーンの一部として(おそらく)J3.5のJxxxクラスの完全なセットを書くつもりです。これには、多くのコンポーネントを入れ替えて新しいものを使用することも含まれます(うまくいけば、3PDの例のWebリンク、新しいフィード、連絡先、およびキャッシュなどの内部で使用されるコンポーネントの一部)。

ただし、これらのクラスはJ2.5では使用できません。つまり、J2.5/3.x互換の拡張機能を構築している場合は、それらを使用できません。削除に関して-J4.0でレガシークラスを削除すると思われますが、これは規定ではありません-拡張機能開発者に移行を行うための十分な時間を与えるために、J5までレガシークラスを保持することもできます。

10
George Wilson

レガシークラスは、現時点ではまだ非推奨ではありません(Joomla 3.3)。したがって、それらをJoomla 3拡張機能に使用することはまったく問題ありません。

新しいMVCに置換クラスがある場合は、それらを非推奨にする最も早い時期です。 George WilsonのGSoCプロジェクトがそれを提供してくれるかもしれません。しかし、コア拡張がこれらのクラスを使用している限り、それらを廃止することは意味がありません。

削除できる最も古いバージョン(非推奨の場合)はJoomla 4.0になります。したがって、Joomla 3.xの場合は、これらを使用しても安全です。

1
Bakual

現在のAPIにはこれ以上の変更はないと思います(混乱やB/Cの混乱を避けるため)。

Joomla 4は次の大きなイテレーションになります。

0
Anibal