it-swarm.dev

Bootstrapバージョンは新しい拡張機能でv2.3またはv3を使用する必要があります

拡張機能の開発者として、私は次の拡張機能でどのBootstrapバージョンを使用するか)がまだ混乱しています。

  • 多くの議論の中で、私はJoomla 3.xがbootstrap-3.0を利用しないことを発見しました。
  • ほとんどのテンプレートプロバイダーはbootstrap v3
  • bootstrap v3も使用する多くの拡張機能

何を選ぶ?

9
Shyam

Joomla 3.xにはBootstrap 2のファイルが付属しており、下位互換性があるため、Joomla 3.xシリーズで変更される可能性はほとんどありません。

Bootstrapは2つの主要な領域で構成されていることを理解することが重要です:

  • CSSファイル
  • JavaScriptフレームワーク

[〜#〜] css [〜#〜]

Joomlaには、ソースLESSファイルとコンパイル済みCSSファイルの両方としてこれらのファイルが含まれています。 Joomla自体は、Bootstrap CSSファイルをロードしません。これらのファイルを使用するか、独自のCSSファイルを同梱するかは、テンプレート次第です。

バックエンドでは、アクティブなテンプレートは通常「Isis」であり、Bootstrap 2個のファイルを頻繁に使用します。したがって、Bootstrap 2スタイルを使用することは理にかなっています特に、とにかく多くの代替管理テンプレートがないため

フロントエンドではしかし、それは完全に異なるトピックです。ユーザーがどのテンプレートを使用し、どのフレームワークに基づくかはわかりません。個人的には、Bootstrap 2のスタイリングをここでも使用します。これは、コア出力もこれらを使用するという唯一の理由からです。したがって、テンプレートがこれらのクラスをサポートする可能性が高くなります。それ以外の場合は、オーバーライドが提供されますコアにオーバーライドを使用する場合、とにかく拡張機能にもオーバーライドが必要になる可能性があります。

もちろん、Bootstrap 3のサポートを追加することもできますが、これは作業を2倍にすることを意味します。ただし、Bootstrap 3のレイアウトをオプションなしで提供することは決してしませんロードするBootstrap 2つのもの。

JavaScript

Joomlaには、ロードするメソッドがありますBootstrapツールチップやタブなどのJavaScriptコード。このコードは拡張機能で使用でき、使用する必要があります。レイアウトでロードして、テンプレートで上書きできるようにしてください。必要。

6
Bakual

すでに指摘したように、Joomla 3.xはBootstrap 3.xを利用しません。したがって、Bootstrap 3、次に、ユーザーは2つのバージョンのBootstrapをロードします。これにより、競合が発生する可能性があり、ページのロード速度も低下します。

あなたができることは、Bootstrapのどのバージョンがテンプレートに電力を供給しているかを検出するための小さなスクリプトを記述し、そのバージョンを使用して拡張機能をスタイルすることです。NoNumberまたはAkeebaは、どちらかを選択する機能を提供すると思いますBootstrap使用したいバージョンです。どちらを使用するか思い出せませんが、どのように使用するかを確認する価値はあります。

しかし、Bootstrapを使用して拡張機能をスタイルするのではなく、カスタムスタイリングを別のオプションとして実行してみませんか?すべてのテンプレートがBootstrapに基づいているわけではありません。

これがあなたに少し洞察を与えることを願っています。

1
Lodder

拡張機能では、拡張機能でBootstrap 2構文を使用するように常に注意する必要があります。これは特にバックエンドで使用します。これはJoomlaコアによって公式にサポートされているバージョンであるため、常にスタイリングは期待どおりに機能し、bootstrapをテンプレートに同梱する必要はありません。Bootstrap 3に同梱される拡張機能には、これを含める必要があります(かなり大きいことに注意してください) Akeeba製品に付属するAkeeba Strapperクラスなど)。

Bootstrap 3を使用するテンプレートプロバイダーは、通常、bootstrap 2構文を許可して、両方のバージョンのbootstrapアカウントです。とにかく、テンプレートのオーバーライドを使用する必要があると期待してはいけません。

Bootstrap 2で、Bootstrap 3に移行しない)でのJoomlaの出荷のポイントは、Joomla全体にab/cクロスエクステンションCSS/JSフレームワークがあることです。シリーズ。

1
George Wilson

Bootstrap 3を使用する必要がある場合、私の意見では、Bootstrap 3 CSS(Community Builder V2のような)フロントエンドにBS3を使用すると、フロントエンドのメニューとモジュールが壊れます。

Community Builderフォーラムからの引用:

元のリンク: http://www.joomlapolis.com/forum/6-news-and-publicity/224106-community-builder-20-b2-released?start=6

しかし、CB2.0はBootstrap 2または3を使用しますか?

ブートストラップ3。

また、CBは常に完全なBootstrapライブラリ、サイトのログインモジュールのみの場合も)をロードします。これは、Bootstrapが不要な巨大なものもロードしているためです。

いいえ、Twitterは使用していませんBootstrap JS。

現時点ではCSSのみを使用しています(JS機能を提供する他のより優れたjQueryプラグインがあります)。 Twitter Bootstrapを名前空間とともにロードするので、名前空間の外でスタイルを競合したり変更したりすることは不可能です。現在、常にロードするわけではありません。template.cssのみをロードします。とCBsテンプレートが読み込まれているときは常にfontawesome.css。注CBsモジュールはCBスタイリングを使用しません。これらはJoomla 1:1に一致するように設計されているため、モジュールはサイトに正しく適合します。

別の解決策は、上記の問題を回避するために、SkeletonやFoundationなどのフレームワークを使用することです。

0
Joomla Agency