it-swarm.dev

Joomla 1.5が実行するPHPの最大バージョンは何ですか?

古いJoomla 1.5を使用しているクライアントがいますが、今年はアップグレードしたくありませんが、ホストはサーバーをアップグレードしたいと考えています。リストされている最小値ではなく、Joomla 1.5が実行するPHPの最大バージョンは何ですか?

http://www.joomla.org/technical-requirements.html#footnote-1xPHP
Joomla! versions 1.5.15 and later are compatible with PHP 5.3.

5.3.10では問題なく実行されますか? 5.4では機能しなくなると思いますが、古いバージョンのテスト用マシンを構築してテストするのは難しいと思います。経験からの質問が増えました。

ありがとう

4
tristanbailey

Joomla 1.5.14またはbelowを実行している場合は、PHP 5.2を使用する必要があります。 PHP 5.3で機能しない可能性のあるコードスニペット

ただし、Joomla 1.5.15またはaboveを実行している場合は、PHP 5.3へのアップグレードで問題ないはずです。 OpenIDライブラリを使用している場合、これはPHP 5.3と互換性がないため、代替を見つけるか、PHP 5.2を使用する必要があります。

PHP、MySQL、Apacheのバージョンの詳細については、 技術要件 を参照してください。

1.5シリーズの最新バージョンであるJoomla 1.5.26にアップグレードすることをお勧めします。

お役に立てれば

5
Lodder

私は同じPHPインストールで、Joomla 1.5.26サイトを構築中の新しいJ3サイトと一緒に実行しています。J1.5サイトはPHP = 5.6何も変更せず、J1.5サイトは非常にシンプルなサイトで、拡張機能はほとんどありません。

4
biltong

Joomla 1.5.24がPHP 5.5.9-1ubuntu4.17で実行されていることを確認します。PHP-FPMはaptでイ​​ンストールされました。Webサーバーはnginxです。すべての機能がスムーズに実行されているようです。

3
Egeshi