it-swarm.dev

アップグレード後にKali Linuxが失敗する

アップグレード後、Kaliが機能しなくなりました。リカバリモードで実行していますが、基本的な通信(http)パッケージに問題があるようです。

私がwgetまたはcurlを試すと、次のようになります。

relocation error /usr/lib/x86_64-linux-gnu/libgnutls.so.30: symbol _idn2_punycode_decode version IDN2_0.0.0 not defined in file libidn2.so.0 with link time reference

一部のファイルは破損していますが、すべての破損を検出して置き換える方法が見つからないと思います。もちろん、wgetなどのコマンドを使用できないため、手動で(USBなどから)実行する必要があります。

ありがとう!

8
Gari BN

私はそれを修正することに成功しました:

  1. 別のコンピューターからlibidn2.so.0 debファイルをダウンロードしてUSBに移動しました。
  2. リカバリモードでは、オフラインでファイルに置き換えることに成功しました。 wget、curl、その他のネットワークコマンドが機能するようになりました。
  3. アップデートとアップグレードを正常に実行し、gnomeをインストールしました。 (アップグレード後、もう一度libidn2.so.0を再インストールする必要がありました)。
  4. 再起動してログインページが表示されます(ただし、以前より時間がかかりました)。

それが役に立てば幸い!

2
Gari BN

ここで私のために働いた修正があります:

私がこれをしたとき、私の箱はライブで動いていました。

まず、debを別のホストにダウンロードします。

wget http://ftp.us.debian.org/debian/pool/main/libi/libidn2/libidn2-0_2.0.5-1_AMD64.deb

次に、問題のあるボックスまでのSCP。

ファイルがボックスに表示されたら。これを実行してください:

Sudo dpkg -i /tmp/libidn2-0_2.0.5-1_AMD64.deb

これはダウングレードで、問題なく更新(apt-get)できました。

この時点では、これが引き起こす問題については知りません。自己責任。

8
Stigs