it-swarm.dev

新しいインストールsession.save_pathエラー

Joomla 1 5.26サイトでローカルで作業する必要があります。

ローカルセットアップWin7、Xampp、Apache 2.4.3、PHP 5.4.7

多数のローカルJoomla 2.xおよび3.x Webサイトがありますが、新しいJoomla 1.5.26 Webサイトをインストールすると、手順2で次のエラーメッセージが表示されます。

エラーが発生しました。:

ブラウザークライアントでCookieが有効になっていないようです。この機能を無効にしてアプリケーションをインストールすることはできません。または、サーバーのsession.save_pathに問題がある可能性もあります。この場合、自分で確認または修正する方法がわからない場合は、ホスティングプロバイダーにお問い合わせください。

同様にStrict Standardsの多くの行:非静的メソッドの警告。

これは、php.iniファイルに正しいsession.save_pathが含まれていないことが原因である可能性があることを読みました。

また、私は数多くのブラウザとデバイスを試したので、ブラウザキャッシュの問題ではありません。権限も正しいようです。

大きな問題ではありません。それは開発者向けなので、可能であれば問題の根底に行きたいです。

6
jonboy

Joomla 1.5は、質問に記載されているように、新しいPHP5.4などのバージョン)向けに開発されていません。新しいバージョンof PHPには、Joomla 1.5が必要とする可能性のある非推奨または削除/置換された関数がある可能性があります。

XamppインストールにPHP5.3.x)をインストールしてから、もう一度インストールを実行することをお勧めします。

個人的には、代わりに Wampserver を使用します。 PHPとMySQLのバージョンを切り替えることも非常に簡単です(1クリック)。Xamppでこれができるとは思いませんが、私は間違っている可能性があります

お役に立てれば

3
Lodder

これは、@ Lodderからの優れた回答への追加にすぎません。これは少し話題外ですが、この種の問題を回避するための別のアプローチを提供します。

現在、開発への推奨される(人気のある)アプローチの1つは、運用サーバーの構成を可能な限りミラーリングする仮想マシンをPCで実行することです。

たとえば、Windows 7の使用について言及しましたが、おそらくLinuxマシンでライブWebサイトを実行しています。ですから、あなたのウェブサイト/開発を事前にテストすることは、とても理にかなっています。

このようなソリューションには、Vagrant with Virtualboxが含まれます。 PuPHPet を使用すると、仮想マシンを必要なもので構成できます。 Joomlatools は、Joomla Webサイト向けの素晴らしいソリューションも提供します。

2
Valentin Despa