it-swarm.dev

services.volumes的不受支持的配置选项

第一次尝试设置docker时,我遇到了卷问题。我对此很有信心,.yml中的间距和格式正确。

我已经尝试过版本3、3.1、3.2、3.3和3.4。所有人都收到相同的错误消息(如下)

Services.volumes的不受支持的配置选项:'db2_prod'

version: '3'

services:
   liberty:
     image: liberty:${liberty_tag}
     ports:
       - "${liberty_ip}:9080:9080"
       - "${liberty_ip}:9443:9443"
     restart: always

   Apache:
     image: webapp:${Apache_tag}
     ports:
       - "${Apache_ip}:80:80"
       - "${Apache_ip}:443:443"
     restart: always

   db2:
     image: db2:${db2_tag}
     ports:
       - "${db2_ip}:50000:50000"
     stdin_open: true
     tty: true
     restart: always
     volumes:
       - db2_prod:/database/stagg3

   volumes:
     db2_prod:
25
Coy

volumes必须与services具有相同的缩进,即

services:
    #...
volumes:
    db2_prod:
69
stacksonstacks